Resolved | Feb 28, 2026 | 08:29 GMT+02:00
Merchant panel login and functionality were affected by technical issues. The problem was between 27.2. 16:40 - 28.2. 08:20. The issue is now fixed and we are monitoring the situation. We apologize for the inconvenience this has caused.
Monitoring | Feb 28, 2026 | 08:28 GMT+02:00
Merchant panel login and functionality were affected by technical issues. The problem was between 27.2. 16:40 - 28.2. 08:20. The issue is now fixed and we are monitoring the situation. We apologize for the inconvenience this has caused.