Incident

Service outage in new payment service

Resolved | Mar 02, 2022 | 14:48 GMT+02:00

There was partial service outage in payments starting 14:27 and ending 14:48. Issue has been corrected.

Monitoring | Mar 02, 2022 | 14:27 GMT+02:00

There was partial service outage in new payment service starting 14:27 and ending 14:48. Issue has been corrected.

Status Page powered by Admin Labs