Incident

Service availablity issues

Resolved | Mar 30, 2023 | 13:55 GMT+03:00

The issue is resolved. We apologize for the inconvenience and we will perform root cause analysis avoid this issue in the future.

Monitoring | Mar 30, 2023 | 12:55 GMT+03:00

Services are functioning again, we are monitoring the situation to make sure everything works.

Investigating | Mar 30, 2023 | 11:55 GMT+03:00

Service is currently having availability issues related to both payment service API and merchant panel. We are investigating the issue and try to restore availability as soon as possible.

Status Page powered by Admin Labs