Incident

Service outage

Resolved | Feb 22, 2021 | 11:52 GMT+02:00

The issue was corrected quickly and further issues prevented by changes preventing bug from occuring again.

Monitoring | Feb 22, 2021 | 11:37 GMT+02:00

Service outage due to bug in backend vendor software.

Status Page powered by Admin Labs