Incident

Technical issue with Mastercard payments

Resolved | Jan 05, 2026 | 15:01 GMT+02:00

The issue has been fixed with Mastercard. The payments and refunds have been working normally since 14:16. The authorization holds that are due to failed payments will be cancelled today.

We apologize for the inconvenience.

Resolution in progress | Jan 05, 2026 | 12:00 GMT+02:00

Technical issue has affected Mastercard payments and refunds since 5.1. Monday 08:00. The issue affects all Mastercard related activity, including Mobilepay, ApplePay and GooglePay.

Issue is caused by problem between card acquiring service and Mastercard and they are troubleshooting the issue. We'll update the status when the issue is fixed.

We apologize for the inconvenience

Status Page powered by Admin Labs