Incident

Merchant Panel is temporarily out of service

Resolved | Jul 26, 2024 | 17:09 GMT+03:00

Merchant panel is now back online.

You can find additional information about the issue here:
https://www.paytrail.com/uutiset/paytrail-havainnut-kalasteluyrityksi%C3%A4-kehottaa-asiakkaitansa-varovaisuuteen

https://www.paytrail.com/en/news/paytrail-detects-phishing-attempts-urges-customers-to-exercise-caution

Investigating | Jul 25, 2024 | 18:34 GMT+03:00

Merchant Panel is temporarily out of service. We are investigating the issue and will provide further information during the day on Friday, July 26th.

Status Page powered by Admin Labs