Incident

Lowered level of service in payments

Resolved | Feb 09, 2026 | 11:35 GMT+02:00

Payment service had reduced level of service between 11:20 - 11:47, part of the payments were unsuccessful during this period. The issue was due to internal changes, that were reverted immediately to return the service level to normal. We are investigating the root cause and we apologise for the inconvenience.

Monitoring | Feb 09, 2026 | 11:20 GMT+02:00

Payment service had reduced level of service between 11:20 - 11:35, part of the payments were unsuccessful during this period. The issue was due to internal changes, that were reverted immediately to return the service level to normal. We are investigating the root cause and we apologise for the inconvenience.

Status Page powered by Admin Labs