Incident

New merchant panel responding slowly

Resolved | Jul 01, 2022 | 15:00 GMT+03:00

Issue with Merchant panel slowness should be resolved now. We apologize for the inconvenience.

Status Page powered by Admin Labs