Incident

Issues with access to www.paytrail.com

Resolved | Sep 06, 2018 | 13:56 GMT+03:00

Issues with www.paytrail.com have been solved.

Identified | Sep 06, 2018 | 11:38 GMT+03:00

www.paytrail.com is currently having some issues due to our service provider. These problems do not affect our payment service, which is running normally. We are trying to solve the issue with our site as soon as possible.

Status Page powered by Admin Labs